Unable to open a realm at path (make_dir() failed)


#1

Hey all.

Im currently using Node.js along with Realm on my PC and ran into an issue.
Upon creating a new Realm, an error is sent to my console which says:

  • Error: Unable to open a realm at path ‘C:\Users\João\Desktop\Web_Project_F-J\post.realm.management’: make_dir() failed: No such file or directory.

It points to this piece of code:

var postRealm = new Realm({
    path: 'post.realm',
    schema: [PostSchema]
});

I have no clue on why this is happening. I already tried to change the path property to other names, to ’ ', and to delete it entirely so a default path can be created. All this with no success.

I am currently following this tutorial:

Thanks in advance,

João.


#2

@JoaoBM More than likely this a permissions or space issue. The realm process needs to be able to create folders and files. Best to check the permissions of your operating system - what version is it?


#3

@ianward Thank you for your reply. I am currently using Windows 10. I had thought of this and tried running Node’s console with Admin rights but with no success. I have never had any problem with permissions in this computer until now, it seems.