Ream Studio 3.0.1 param 1 must be of type string


#1

After upgrading from v 2.9 I cannot login anymore, on ‘Other’ tab pressing connect always leads to
“Couldn’t connect to Realm Object Server:
param 1 must be of type string”
What is actually missing? The creds are the same that are working ok on v 2.9


#2

We made some changes to how Studio handles authentication with 3.0.0. Can you share an example payload that’s causing this error (feel free to obfuscate any usernames/passwords).


#3

Sure, that is what i post into multiline textfield on the Other tab

{
“provider”: “someprovider”,
“userInfo”: {
“username”: "[email protected]",
“password”: “somepassword”
}
}

Thank you