Realm Xcode 10.2 and Carthage


#1

Xcode 10.2 borked my Realm install. I had just copied the binaries over manually. As there aren’t any new binaries yet, I deleted them and I tried installing with Carthage. Carthage is giving me these errors. My project is using Swift 4.2 by the way.

Build system information
error: SWIFT_VERSION ‘3.0’ is unsupported, supported versions are: 4.0, 4.2, 5.0. (in target ‘RealmSwift’)

Build system information
warning: Swift 3 mode has been deprecated and will be removed in a later version of Xcode. Please migrate “RealmSwift” to Swift 4.2 using “Convert > To Current Swift Syntax…” in the Edit menu. (in target ‘RealmSwift’)

Any ideas on what is going on? Better yet is there anywhere just to download the new binaries. I’ve never had much luck with Carthage and Cocoapods.


#2

Disregard this post. They updated the binaries to work with 10.2 so everything is working again.