Realm Studio can't access instances on Realm Cloud after connecting with Realm 4.1.0


#1

I’ve upgraded App to use realm 4.1.0. After having used it to connect to Realm Cloud, I cannot connect to the realm on Realm Cloud using realm Studio.

I’m getting a greyed out page saying “(bad client version (IDENT, UPLOAD)” with a Reconnect Button that repeats the problem when pressed.

I’ve raised this issue on private support (since this is actually a production system) but support seems unresponsive.


#2

@nirinchev Sorry for hailing you, but i’ve got an instance on Realm Cloud that I can’t get to. Realm Studio won’t connect. Is it something that you’re on? I need access.


#3

Hm… I’ll ping the support team and have them take a look. In the meantime, you can try clearing Studio’s cache and see if that makes a difference. It should be under Help -> Clear Cache.


#4

Did not know that one. It seems to fix the issue. Thank you!


#5

Hi I have a very similar problem, but clearing the cache doesn’t help:
On 3 WIN 10 machines we are using Realm Studio (2x 3.61 1x 3.5 ) for checking our production system. When selecting the required instance, we get:

  • Your instance is ready Connecting to … v3.25.3 with a yellow indicator
  • the indicator switches for a partz of a second to green
  • then to red with: Failed v3.25.3
  • and the message "Bad client version (IDENT, UPLOAD) appears.

But there is no problem, when connecting to the 2 other instances.
Fortunately our application is still running fine …


#6

Hi, my issue is solved by the realm-support, with the following steps:

  1. Uninstall Realm Studio
  2. Got to the AppData folder under your user directory and check for Realm Studio files, this will typically be under User Name > AppData > Roaming > Realm Studio
  3. Save any files in the logs folder for further support (it was empty)
  4. In the folders starting with renderer-* copy the files to a safe location (support can use this to find the root cause later)
  5. Remove data in this folder
  6. Reinstall Realm Studio 3.6.1 (You must be running windows 8 or higher)
  7. If the issue is solved please provide a zip file with the renderer-* directories you saved before