Query-based realm as default in 2.8

cloud

#1

Hi,

I am using ver 2.7.2 of realm.

I understand from the documentation that in 2.8 you made a new realm by default to be opened as query-based realm.

First question - assuming i will not upgrade to 2.8 - how do I open now a query-based realm? Cant find the docs - if I remember correct I need to define “sync:partial” or something like this in the configuration object?
I tried to convert the realm object via the Realm Studio to reference but its still not recognizing this as partial realm in the code.

Second question - what will happen if I will upgrade to 2.8 ? do I need to add the property “fullSynchronization: true” to all my config files?

Thank you.


#2

@yuvalkro By default, with the latest version, sync is query-based by default. You will need to specify your full sync realms like so:
https://docs.realm.io/platform/using-synced-realms/opening-a-synced-realm#fully-synchronized-realms