Pattern or Technique to sync local Realm (Xamarin) with Cloud Realm

cloud

#21

@nirinchev
I’m afraid not. It’s a running requirement. We have multiple companies. Each with a realm of their own. Partial sync is not really usable for the seperation of companies. Even if ApplyPermission worked, stamping permissions on each and every object instance is not the way forward :slight_smile:

So I’m stuck with full sync, where Azure needs to be able to create realms and users.

I’ll code around the current issues by making a conversion table between our company numbers and userid’s.

Thanks for your efforts. They are much appreciated. And please still ping me when the SSL fix arrives.


#22

@void we’ve published a prerelease package that should resolve the Android issue - can you try to install it and let me know if it resolves the Windows problem as well? Here are the instructions on how to get it.


#23

@nirinchev
I can see that realm cloud has been upgraded to 3.9.0 (from 3.6.5 ?)
ApplyPermission seems to work now.
Great stuff


#24

Glad to hear that :slight_smile:


#25

@nirinchev

when I run on Mac/Windows, but not on linux (ubuntu). Any ideas why?


#26

That’s odd… did you update to the latest version of the .NET SDK?


#27

@nirinchev

Same code. Just deployed to linux.

Could this be a variant of ApplyPermission and SSL?
If so, why is SSL even a factor in applying permissions to a user?


#28

@nirinchev

So. Running 3.10 locally on my mac, or on Azure succeeds with ApplyPermission. ApplyPermission does not succeed using 3.10 when running on linux on Digital Cloud droplets.

Unfortunately Digital Cloud does not support windows. And mac is not an option.

I’ve got EnableSSLValidation set to false on the configuration, but I suppose that plays no part in the ApplyPermission call to the server.

Could we get an overall EnableSSLValidation for authorisation calls? Or perhaps supply an app-key to for some realm custom encryption in order to opt out of the SSL layer? If SSL really is the problem of course.


#29

SSL should not be the problem with 3.1.0. Do you know what’s the Linux distribution on Digital Cloud? I can try and reproduce it locally tomorrow.


#30

Sure. I’m using ubuntu-s-4vcpu-8gb-fra1-01 => Ubuntu 16.04.4 x64

Let me know if there is something I can try.


#31

@nirinchev

An update. Looks like our linux server has called your AWS servers since ApplyPermission failed yesterday - or perhaps before - i can send you the logs in a private message if you need them. We’ve got a log full of :

Connected to endpoint ‘35.166.14.39:443’ (from ‘xx.xx.xx.xx:xxxx’)
ERROR: Connection[3]: SSL handshake failed: certificate verify failed

This is probably also the cause of : Realm Cloud "tick-over" where we are seeing a 10 mb spike this morning.


Realm Cloud "tick-over"
#32

@nirinchev

Did you get a chance to have a look?


#33

Not yet - I delegated it to @fealebenpae as I’ve been needed elsewhere. He’ll update the thread when he has anything to share.


#34

I’m extremely sorry this took so long to fix. @void, I know you’re speaking with our support team directly, but for anyone else who needs that, we have prerelease packages that should resolve the SSL issue:

Realm.nupkg
Realm.Database.nupkg

While these are generally stable and unlikely to introduce regressions, they haven’t gone through all the release-assоciated testing. I expect we’ll push an official version 3.2.0 early next week.