Migration is required error for multiple configurations and files


#1

I have 2 realm configurations (and files):

  • first has schema version 25 and migration block which executes when app updates from version 24
  • second is version 1 and no migration blocks

On second realm initializing I have an error: "Error Domain=io.realm Code=10 “Migration is required due to the following errors:”

I cannot understand why the second realm needs migration? Should I use the same schema versions for two configurations? Do I need a migration block for the second configuration?