Is Realm 3.14.1 ready to be used with Xcode 10.2


#1

I have a project where I’m using Swift 4.2 and WatchOS 3.1, I recently had to update to Xcode 10.2 since my testing device was automatically updated to iOS 12.2 so, I could no longer use it for testing in Xcode 10.1 anymore (testing with the simulator is not an option for me at this point).

  1. Is Realm 3.14.1 ready to be used with Xcode 10.2?

  2. In theory, is Realm 3.14.1, folder Swift-10.2 ready to be used in a project using Swift 4.2 in Xcode 10.2?

The reason for the question is because I downloaded Realm 3.14.1 added it to my project and I keep getting the following error.

realm-error

Module compiled with Swift 4.2 cannot be imported by the Swift 5.0 compiler: /Users/userName/MyApp/RealmSwift.framework/Modules/RealmSwift.swiftmodule/i386.swiftmodule

Thanks