Debugging on iOS



I have just installed Realm on a react-native project and now I am unable to use remote debugging.
I get an error: -

POST http://localhost:8083/create_session 404 (Not Found)

ExceptionsManager.js:73 Error: HTTP/1.1 404 Not Found
    at makeRequest (rpc.js:209)
    at sendRequest (rpc.js:240)
    at Object.createSession (rpc.js:55)
    at index.js:199
    at loadModuleImplementation (require.js:212)
    at guardedLoadModule (require.js:146)
    at _require (require.js:130)
    at index.js:106
    at loadModuleImplementation (require.js:212)
    at guardedLoadModule (require.js:146)

I have tried installing different versions of realm back to 2.0.1, which was the last version that I used on a react-native project without any issues, however I always get the same error.

I have tried running on the iOS Simulator with iOS versions 11.4 and 11.1

Searching for this issue I have found references to other people having the issue with Android and using ADB to forward ports, but as this is iOS I don’t think that it will help me.

Does anyone have any ideas?


I have managed to get my debugging working again.
I opened up and changed the port number back to 8082.
I am not sure why this has worked, but I seem to be able to use remote debugging again.