Authentication error


(Froi) #1

Hi,

Following the instructions to implement a sync app to Realm Cloud using iOS/Swift, I got an authentication error in this step:

https://docs.realm.io/sync/getting-started-1/ios-quick-start/step-1-my-first-realm-app#testing-authentication

Error in the Realm Studio app logs section:

HTTP response: e749b9f3-f3b1-48b1-a8b5-b681ffb0dfb1 {"type":"https://docs.realm.io/server/troubleshoot/errors#invalid-parameters","title":"Your request parameters did not validate.","status":400,"code":601,"invalid_params":[{"name":"provider","reason":"Invalid parameter 'provider'!"}]}

Thanks for the help.


(Zsolt Jandzso) #2

I searched this error on the forum:
Are you using JWT?


(Froi) #3

Hi,

No, I’m not using it.

Thanks.


(Zsolt Jandzso) #4

What is your url? Do you use the 9080 port?


(Froi) #5

I think maybe I was wrong about the solution I choose in the form: I’m using the cloud solution managed by Realm Studio app, it’s not a dedicated server.


(jay) #6

If you’re going through the quickstart guide, the documentation is wrong for authentication

See Nickname Authentication Change

Jay